El blog de PlanillaExcel

Cómo calcular el promedio (o media) en Excel

En este video-tutorial te explico como calcular el promedio en Excel con la función PROMEDIO, como obtener el promedio con condiciones a través de la función PROMEDIO.SI y PROMEDIO.SI.CONJUNTO y cómo obtener un promedio sin contar los ceros.

El promedio se lo puede definir como el valor "central" calculado entre un conjunto de números. 

En matemática el promedio es llamado media aritmética o media y se obtiene al dividir la suma de un conjunto de números por la cantidad total de números que hay.

Por ejemplo, en el caso de que quisiera obtener el promedio final que tiene un estudiante, debo sumar el puntaje que logró en cada materia, por ejemplo 8, 7, 9,  y luego dividir ese resultado por la cantidad de materias, en este caso 3. Por lo cual el promedio resultaría en (8+7+9)/3 =8

Para obtener el promedio o media aritmética en Excel no necesitamos hacer estos pasos, simplemente llamamos a la función PROMEDIO.

 

Explicación

Fórmula general

= PROMEDIO(número1, [número2], ...)

Como obtener el promedio en Excel

 

Aplicando la función promedio sobre el rango de datos, obtenemos el resultado.

=PROMEDIO(C5:F5)

 

Promedio con una condición: PROMEDIO.SI
A veces necesitamos obtener el promedio de acuerdo al cumplimiento de una condición o criterio. Afortunadamente en Excel existe una función para eso llamada: PROMEDIO.SI.
 
Fórmula general

=PROMEDIO.SI(rango; criterio; [rango_promedio])

>> Rango: Rango de datos donde buscará el criterio

>> Criterio: Condición que debe cumplirse para que se aplique el promedio. Puede ser un texto, una celda, un operador lógico, caracteres comodín.

>> Rango promedio: Rango donde se aplicará el promedio al cumplirse la condición. Es un argumento opcional, si se omite se utilizará el primer argumento (Rango) para aplicar el promedio.

 

En este ejemplo necesitamos obtener el promedio de precios de departamentos correspondientes al barrio de Flores.  

Promedio con condición

Para eso haremos

=PROMEDIO.SI(B2:B15;"Flores";E2:E15)

1.- B2:B15 representa el rango donde buscará el criterio.
2.- "Flores": es el criterio que debe cumplirse y debe escribirse entre comillas.
3.- E2:E15: rango de valores donde aplicará el promedio si cumple el criterio. 

Promedio con condiciones

El criterio también lo podríamos haber seleccionarlo de la celda G3 en lugar de haberlo escrito dentro de la función. En ese caso no necesitamos incoporar las comillas:

=PROMEDIO.SI(B2:B15;G3;E2:E15)

 

Operadores lógicos en el criterio
Condiciones como mayor que, menor que, diferente a, etc se utilizan con frecuencia en funciones condicionales.

Si de este mismo ejemplo, queremos obtener el promedio de precios de aquellos departamentos que tengan 3 o más ambientes, en el criterio debemos escribir entre comillas el operador mayor e igual de esta manera:

=PROMEDIO.SI(D2:D15;">=3";E2:E15)


promedio en excel

Esto aplicaría para también para el operador menor, menor igual, mayor y diferente.

 

Criterios que coinciden parcialmente: utilización de caracteres comodín.

Podemos usar caracteres comodín en el criterio para realizar un promedio de las celdas basados en coincidencias parciales.

>> El  signo de pregunta  (?) se utiliza para un sólo caracter. Por ejemplo R?ma buscará Roma o Rama.
>> El asterisco (*) se utilizar para coincidir más de un caracter. Por ejemplo Polo* buscará Polo Tecnológico, Polo Gastronómico, Polo Científico, etc.

Si quiero saber el promedio de valores de aquellos departamentos que quedan en Palermo independientemente de que sea Hollywood, Viejo, Soho, etc, podemos usar el asterisco de esta manera:

 =PROMEDIO.SI(B2:B15;"Palermo*";E2:E15)


Promedio Excel

 

Promedio con varias condiciones: PROMEDIO.SI.CONJUNTO

Si quisieramos obtener el promedio donde más de un criterio debe cumplirse obligatoriamente, podemos usar la función PROMEDIO.SI.CONJUNTO:

 PROMEDIO.SI.CONJUNTO(rango_promedio; rango_criterio1; criterio1; [rango_criterio2; criterio2]; ...)

1.- Rango_promedio: Son las celdas que contienen los valores de los que obtendremos el promedio.
2.- Rango_criterios1 El rango de celdas que contiene los valores que serán evaluados con el criterio 1.
3.- Criterio1: El criterio con el que serán evaluadas las celdas del Rango_criterios1.
4.- Rango_criterios2: El segundo rango de celdas con los valores que serán evaluados por el Criterio2.
5.- Criterio2 : El criterio con el que se evaluará el Rango_criterios2.

Por ejemplo quisiera saber el promedio de precio de departamentos en Belgrano de 90 m2 tendríamos 2 condiciones que se deben cumplir.

 =PROMEDIO.SI.CONJUNTO(E2:E15;B2:B15;"Belgrano";C2:C15;90)

Donde:

>> E2:E15 es el rango de valores.
>> B2:B15 es el rango donde figuran los barrios.
>> “Belgrano” es el primer criterio.
>> C2:C15 es el rango donde figuran los metros cuadrados.
>> 90 es el segundo criterio.

Promedio con varias condiciones

Esta función permite introducirle hasta 127 criterios (o condiciones).

 

Promedio sin contar ceros

A veces cuando queremos sacar el promedio podemos encontrar en nuestro rango de datos los valores ceros.  El cero se asume con un número más y se realiza el promedio. Pero ¿qué sucede si no queremos tener en cuenta los ceros en nuestros cálculos?
Por ejemplo aquí queremos obtener el promedio de ventas de los representantes sin tener en cuenta aquellos meses donde no vendieron nada.

Promedio sin ceros


Tenemos que pensar en una variante para calcular el promedio y para eso usaremos la función PROMEDIO.SI cuyos argumentos serán sólo 2:

 =PROMEDIO.SI(B4:G4;"<>0")


>> B4:G4 es el rango de datos de ventas. 
>> El criterio que se utilizará será un operador lógico "diferente a" junto con el cero y se especifica entre comillas:  “<>0”.

El ultimo argumento no es necesario establecerlo ya que tomará como rango de datos para calcular el promedio, las ventas.

Como verán el resultado de un promedio teniendo en cuenta los ceros o quitandolos del cálculo es muy diferente entre sí.

Promedio sin ceros
 
 

¿Conocías estas alternativas de cálculo de promedio? ¿Cómo haces para calcular el promedio? Contame en los comentarios de abajo,

 

¡Saludos!

Cecilia - www.planillaexcel.com


PD: si quieres aprender más de Excel, dicto cursos online desde el nivel básico a avanzado.
Haz click aquí para ver los cursos.