El blog de PlanillaExcel

Cómo encontrar datos faltantes con la ayuda de Contar.Si

Si quieres comparar 2 listas y encontrar los valores de una lista que faltan en la otra, puedes hacerlo a través de una fórmula sencilla basada en la función CONTAR.SI.

Imagina que tenemos una lista de comida para mascotas y debemos compararla con una lista nueva que nos envió el proveedor. ¿Cómo hago para saber cuáles productos de la lista antigua ya no están en la lista nueva?

Como encontrar datos faltantes con contar.si


En este videotutorial te explicaré en 4 minutos como hacerlo:

 

Explicación:

Fórmula General:

=SI(CONTAR.SI(Lista_nueva;Elemento_lista_antigua)=1;0;1))

donde:
Lista_nueva = D2:D47
Elemento_lista_antigua = A2 . Este elemento va cambiando a medida que copiamos la fórmula hacia abajo.

Funcionamiento:
Analicemos primero la función CONTAR.SI

CONTAR.SI($D$2:$D$47;A2)

Esta función cuenta las veces que está el producto de la celda A2 (Adulto Raza Grande 1Kg) en la lista nueva de productos que va del rango D2 a D47.  

Como este producto está en la lista nueva y aparece una vez, arrojará 1 como resultado


CONTAR.SI($D$2:$D$47;A2) = 1

Dado que nuestra idea es contar aquellos productos que no están en la lista nueva, utilizaremos la función SI para establecer que:

• Si el resultado de CONTAR.SI es 1 (que quiere decir que el producto está en la nueva lista) que devuelva 0, ya que no lo queremos contar.

• Si el resultado de la función CONTAR.SI es 0 (quiere decir que el producto no está en la lista nueva) que devuelva 1 para poder contarlo.

 
Así, agregamos la función condicional SI

=SI(CONTAR.SI($D$2:$D$47;A2)=0;1;0)

Replicando esta fórmula para el resto de las celdas de la lista antigua; tendremos una colección de 0 y 1.

Las celdas que poseen 1 indicarán los productos que faltan en la lista nueva que nos dio el proveedor. 
Como encontrar datos faltantes en una lista

 

¿Cómo haces tú para encontrar los valores faltantes en una lista? Cuentanos en los comentarios de abajo.


Espero que te haya ayudado. 

Saludos

Cecilia - www.planillaexcel.com

PD: ¿Quieres aprender más de Excel? Dicto cursos online desde el nivel básico a avanzado  Haz click aquí para ver los cursos.